Browsed by
Tag: CRM

CiviCRM: Missing indexes after upgrade

CiviCRM: Missing indexes after upgrade

After upgrading our CiviCRM we got a notification about missing indexes. It turns out (according to stack overflow) it’s pretty easy to solve if you have drush installed. List all missing indexes drush ev ‘civicrm_initialize();print_r(CRM_Core_BAO_SchemaHandler::getMissingIndices())’ (re)Create all drush cvapi System.updateindexes

CiviCRM: Mixed content error

CiviCRM: Mixed content error

Recently I encountered an error on a CiviCRM profile page, where the reCaptcha gave me a mixed content notification. The whole site is running on https. I solved it by adding this to the CiviCRM config. define(‘FORCE_SSL_ADMIN’, true); $_SERVER[‘HTTPS’]=’on’; // (provided the SSL Certificate is working correctly) Found this here.

Error: This can indicate that a key is not being regenerated correctly.

Error: This can indicate that a key is not being regenerated correctly.

Recently we had the following error occur on our Dynamics CRM installation: Current key (KeyType : CrmWRPCTokenKey) is expired. This can indicate that a key is not being regenerated correctly. Current Key : CrmKey(Id:XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX, ScaleGroupId:00000000-0000-0000-0000-000000000000, KeyType:CrmWRPCTokenKey, Expired:True, ValidOn:02/06/2015 17:39:15, ExpiresOn:03/11/2015 17:39:15, CreatedOn:02/06/2015 17:39:15, CreatedBy:NT AUTHORITY\NETWORK SERVICE. Turns out this was due to a service not coming up correctly after a power failure. Make sure Microsoft Dynamics CRM Async (maintenance) service is up and running. Restart the non maintenance one or…

Read More Read More

How to upgrade CiviCRM

How to upgrade CiviCRM

The following will describe how to update an existing CiviCRM installation to a new version. Always make sure you backup the database and the plugin folder, before proceeding. Download the latest Civi (for drupal in this case) to your plugins folder (or any other folder). wget “https://download.civicrm.org/civicrm-4.7.19-drupal.tar.gz” Note: When upgrading from 4.0.1 do not upgrade to 4.5 in one go. I found that this breaks your civi installation with an error: Fatal DB error, exiting, seems like your schema does…

Read More Read More